
AFM image processing and analysis 

All measurements and measurement techniques are prone to artefacts. In AFM imaging, these artefacts 
are sometimes easy to spot and sometimes very difficult. Some artefacts can be easily avoided, if the user 
knows what to look for and knows the source of the artefact. A few artefacts are unavoidable, but knowing 
that they exist in an image helps to avoid misinterpreting them as genuine image features. This means 
that recognizing image artefacts is very important for the AFM user. 

Therefore, some image processing is usually necessary before viewing or analyzing any AFM image. All 
processing is done with the aim of clarifying the data obtained during measurement. In other words, the 
purpose is to make it easier to measure and observe the features that have been measured. 

 

Because image processing operations can also introduce artefacts in the image, they 
should only be used when necessary! Which processing operations will be used depends 
highly on the image and the properties we want to measure. 

For the processing of the AFM images we will use Gwyddion, which is free and open source software for 
SPM (Scanning Probe Microscopy) data visualization and analysis. All information about this software can 
be found at http://gwyddion.net 

1. Levelling 

Various types of image levelling operations are usually the first processing operations carried out on the 
AFM image data and often the only processing step used on AFM image data.  

1.1. Line median matching 

During imaging it can sometimes happen that cantilever change the level of interaction with sample or 
some mechanical disturbance can cause shift in the laser beam deflection. This will cause the jumps in the 
AFM height image on the slow scanning axis. That is why it is sometimes necessary to first do the line by 
line height median matching.  

 

To do this in Gwyddion go to 

Data Process -> Correct lines by matching height 
median 
 
This will do the height line median matching for 
all horizontal lines of the AFM image. 



  
Before After 

Image 1. AFM image of the EPFL logo grating before and after 
the line by line height median subtraction operation 

On the images above, you can observe that, while this operation did some successful leveling on the upper 
part of the image, it introduced new leveling artifacts on the border areas of EPFL logo. So this operation 
should not be used on the images where there is a horizontal sample with large height difference with 
respect to the background. Misuse of this operation could also be explained on the example of vertically 
and horizontally imaged collagen fiber, on the images below. 

  
Collagen fiber, vertically imaged, before line 

median matching operation 
Collagen fiber, vertically imaged, after line 

median matching operation J 



  
Collagen fiber, horizontally imaged, before line 

median matching operation 
Collagen fiber, horizontally imaged, after line 

median matching operation L 

Image 2. AFM images of vertically and horizontally imaged collagen fiber,  
before and after the line by line height median matching operation 

 

 

In the case of horizontally imaged collagen fiber, we lost the height information of our 
collagen sample by doing the line median matching operation! 
 

In the case of the artefacts on the EPFL logo image, these can be better removed by using the Tools->Level 
rows using intersections with given lines. With this operation we can actually select on which part of the 
image we want to apply line median matching operation. This is shown in the images below. 

 

To do this in Gwyddion go to 

Tools->Level rows using intersection with 
given lines 

Select the lines on which you would want to do 
the line median subtraction and click Apply. 



 
 

Before After 

Image 3. AFM image of the EPFL logo grating before and after 
the line by line height median matching operation on specific areas 

 

1.2. 1st order plane levelling 

If the background in the image (such as the substrate on which the sample was deposited) has 
considerable tilt in it, the change in height of the background will mask the changes in height associated 
with the sample. This effect is shown in the image below. 

 

Image 4. AFM image before and after background tilt removal 

This effect can be removed in two ways: 



1.2.1. Plane subtraction 

 

In order to do the plane subtraction, in Gwyddion go to 

Data process->Level data by mean plane subtraction 

By clicking on it, Gwyddion will automatically calculate the 
background plane and subtract it from the image. 

 

 

This operation should not be applied if the 
sample has large height difference with respect 
to the background because it will not properly 
flatten the background tilt! 

 

1.2.2. Three-point fitting 
 

This procedure is similar to plane subtraction, but is a rather more ‘manual’ and often more accurate 
approach. In this method, the AFM user identifies three points on the image to define the plane to 
subtract.  

 

In order to do the three-point fitting, in Gwyddion go to  
 
Tools -> Level data by fitting the plane through a three points 
 
 



 

Set Averaging radius of the points to 10 px. 
Now select 3 points in image background, as 
far away from each other as possible and 
click Apply. Image should now be levelled. 
Click Clear to remove the points and close 
Three point level window. 

  

Before After 

Image 4. AFM image before and after three-points plane fitting 

 

1.3. Higher order levelling 

A common problem in AFM images is scanner bow. It occurs mainly in instruments that use tube scanners, 
and is caused by a swinging motion of the free end of the scanner. This leads to a curve in the image plane 
as shown in image below. 



 

Image 5. Effect of scanner bow on the AFM image 

In order to remove this curve and similar image distortions that can arise from AFM system, or the 
background tilt - if the background is not perfectly flat, we will use higher order polynomial two-
dimensional curve fitting. This processing works well where the background (on which the sample is 
deposited) is really flat, and does not include any curvature. Typical examples of this case would include 
nanoparticles, micro-organisms on glass slides, or individual molecules on mica. 

If AFM microscope uses a flexure scanner instead of a tube scanner, scanner bow will not be an issue. 

But, before doing this step, we would like to select our sample to exclude it from the two-dimensional 
curve fitting, because we want to do the 2D curve fitting only on the sample background. 

 

To do this in Gwyddion go to 
Data Process -> Mark grains by threshold 
 



 

Check Threshold by: Height and change 
the percentage of the Height parameter 
until the entire sample is selected, then 
click OK 

 

Now we will do the higher order polynomial two-dimensional curve fitting. 

 

To do this in Gwyddion go to 
Data Process -> Remove polynomial background 

 

Set value for Horizontal polynom degree and 
Vertical polynom degree parameters (2-3). 

In the Masking Mode part check the Exclude 
masked region option. This will exclude our 
previously selected sample from the 2D curve 
fitting. 

Click OK. 



  
Before After 

Image 6. AFM image before and after higher order 2D curve levelling 
After this is done, to deselect the sample selection, again go to Data Process -> Mark grains by threshold, 
uncheck the Threshold by: Height and click OK. 

2. Extracting profiles 

Many times it is necessary to extract line profiles from the image in order to examine certain sample 
characteristics. Since it is usually difficult to measure dimensions directly from AFM images, line profiles 
are usually extracted in order to measure dimensions from the AFM images. Gwyddion allows the user to 
arbitrarily define lines to be extracted, and these can be at any angle. 

 

To do this in Gwyddion go to 

Data Process -> Extract profiles 

Clicking once on this button external window will open 
to show line profiles. 



 

Draw a line using mouse. If you hold SHIFT 
button while doing this, lines will be drawn 
only under certain angles (use this to draw 
horizontal and vertical lines). You can draw 
more than one line. 

 

In the external window you will get line 
profiles. 

 

3. Color palettes 

The color palette used to display an AFM image can be selected to make the image seem more visually 
compelling. In some cases, selecting a specialized color pallet can help with visualizing certain aspects of 
an image.  



 

In Gwyddion you can change the color palette by 
right clicking with mouse on the colorbar located 
on the right side of an AFM image.   

 

4. 3D Data representation 

AFM height data is inherently three dimensional (3-D). However, the standard method of rendering AFM 
data shows a two-dimensional (2-D) image, using a color scale to represent height information. This is not 
a normal way for humans to see shapes, and can make interpretation difficult. In particular, for viewers 
unused to AFM data, it can be difficult to determine which features are higher than others, etc. One way 
to overcome this is to render the height information as a pseudo-three-dimensional image. The ability to 
display images that show what we want is vital, to make use of AFM data. 

 

To present AFM image in 3D, in Gwyddion go to 

View->Display a 3D view of data 

 

This will present AFM image in 3D. On the right, 
there is a menu to process 3D image.  

 Use this button to enter advanced menu 
with possibilities such as choosing a color palette, 
choosing whether to show labels and axis, 
choosing type of lighting etc. 

 Use this button to rotate 3D AFM image. 

 If you selected the Lighting type of image 
presentation in advanced menu, use this button 
to change the spot of the light source. 

 Use this button to save 3D image. 



 
5. 2D FFT Analysis 

In AFM image processing and analysis, a two-dimensional Fourier transform is an operation that converts 
the AFM image from the spatial domain, into the frequency, or more correctly, the wavelength domain. 
This is carried out by a mathematical operation known as a fast Fourier transform, so is sometimes also 
known as FFT analysis. When transformed into Fourier space, the image will show features in terms of 
wavelength (or frequency). This is particularly useful to identify any repeating patterns in the image. For 
instance, 2D FFT can be used to calculate period of atomic lattice parameters, depth of corrugations on 
the collagen fibers etc. The Fourier transform can also be used to identify the frequency of noise in an 
image and to remove it. 

To do the 2D FFT in Gwyddion first open an image you want to apply it to. 2D FFT image will be much 
clearer if it is applied to the squared image (equal number of pixels on horizontal and vertical axis). So, to 
do this first go to Data Process->Basic Operations->Square Samples. Then do the 2D FFT by going to Data 
Process->Integral Transforms->2D FFT.  

 

External window will be opened to set FFT parameters. 
You can leave default parameters and click OK.  
 

 

You can click on the View->Zoom in button to zoom 
into 2D FFT image details. 

 

Use on this image the Extract profile tool (which has 
already been explained), to determine period and 
spatial frequency of the measured pattern (e.g. period 
of the collagen corrugations). 

 

Gwyddion file handling 

Opening file: 



Go to File->Open and then find the directory of the file you want to open. Once you click on the file, on al 
the images that the file contain will  be shown on the right.  

 

Image 7. Opening file in Gwyddion 

Once the file is opened, to open/close desired images, that you wish to process and analyze go to 
Meta->Show Data Browser. The images that are checked will be opened. But be aware that if you uncheck 
all of them – the opened file close! 



 

Image 8. Opening images within the file in Gwyddion 

Saving file: 

To save the file (containing all the images) go to File->Save as. Find the folder you wish to save your file 
in. Then, at the bottom of the window chose the proper extension of the file .gwy. On the top give the 
desired name to your file, but make sure to type it with the extension, e.g. name_of_the_file.gwy. Then 
click Save. You can also save just single image, by choosing one of the image formats, but also make sure 
to type the desired image name with the proper extension (e.g. name_of_the_file.png). 



 

Image 9. Saving file in Gwyddion 


